You are here

How the heck do you play this locally?

20 posts / 0 new
Last post
How the heck do you play this locally?
Seriously how?
Its says you can play locally but there is only a play on server option?

Do you have to run a Lan Server?
I tried this but when I try to connect to my Lan server after starting it with the 'startlanserver.bat' it says the server is NOT accepting users?
Even just starting the game and letting the local server start up I still cannot connect and get the same message that the server is not currently accepting users?

And I would love to change my username, any way to do that?


This forum and website, is being re-launched with a complete overhaul.

Dont manually start the LAN server, it will start itself.

The LAN server is at the top, green:



Usernames can't be changed.


My Lan server never looks like that, I get NO Server name and like I said when I connect to it it fails telling me I that no users are being accepted and to talk to the server admin :P


can you start a cmd prompt and type ipconfig

and paste output here.

Windows IP Configuration

Ethernet adapter Local Area Connection:

   Connection-specific DNS Suffix  . :
   Link-local IPv6 Address . . . . . : EDITEDOUT
   IPv4 Address. . . . . . . . . . . :
   Subnet Mask . . . . . . . . . . . :
   Default Gateway . . . . . . . . . :

Ethernet adapter Ethernet:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :

Also in the process of reinstalling the game as well.

**UPDATE** Reinstall did nothing :(


we have made a fix on our side, and a new update will go out in 2-3 days.

can you use the cloudserver instead ?


I can do that, glad to see its not just me that is having the issue.

try now ...

It downloaded some updates then the game went to install them and there was an exception and now my main exe to start the game is missing.

Going to do a fresh install.
OK did a fresh install and same thing happened...

Get this message after it says Buildaworld is updating...

Then try to run the game again and it tells me that the shortcut on my desktop is no longer valid because the 'BAWclient.exe' is missing.
OK so I uninstalled Buildaworld and made sure all folders from
-Program files
were deleted as well.

Then rebooted and reinstalled the game.
This time it installed and got to the point were it asked me if I wanted to run the game in Full Screen.
I said yes then the game did not launch.
I then tried to run the game again but the BAWClient.exe is gone again.
No viruses, 'New' folder is empty, Windows 10. And the game was installing and running with No issues before the update.
Going to try a reinstall with my 'Antivirus' disabled.
OK so I was able to install the game and get it running with NO issues with my antivirus disabled (Avast Antivirus). Also the local Lan server is now working   Thanks for the assistance.
I am running Arch Linux x64 and am also unable to see any local LAN servers. Additionally, when trying to connect to a cloud server, I am told that I must update my client. I just did a fresh install. I purchased it because I thought there might be a bug in the game preventing me from using a local LAN server on Linux. Unfortunately it seems I can not do either. Please advise? I am not willing to discontinue use of my antivirus software just to play this game, however I would be happy to open a port in my firewall if you believe that is what may be causing it. I saw no evidence of a port being blocked in either my local computer's logs or in the BAW logs, and was unable to find documentation on your site identifying what port I should try unblocking. Please advise?
Still stuck here. I've found that the listening port for inbound connections seems to be 4980. However opening that port doesn't have any success. Outbound port appears to be on 443, which is standard HTTPS, so I know that's working. Still the same problem: local server is running, as I can see it in my processes, but I cannot see it from within the BAW client. BAW client also cannot connect to yezBAW's server or to my own cloud server. I've done a fresh install again, and the exact same issue persists.

 The message I get when I try to connect to a cloud server, any cloud server, is:

"Version mismatch. Can not connect. Client version does not match Server version. Build A World must be updated!"
Ahah! Progress... able to get a local server to appear in the client. Had to poke a hole in my firewall for UDP Port 4980 Inbound. Very strange that a local server would need a hole in the same firewall on which both the client and server are running.

Still unable to connect to a cloud server, same messages as before posted.


Unless we get a support issue mail, we are unaware of any issues.

For a long time we were under the impression that nobody except for me (the graphics developer) used the Linux client, hence we did not notice that the production release was 0.0000002 of a version behind.

We had more inquiries about the Linux client and we also released a new major version with tons of new features such as mobs, new sky with realistic clouds and a Spanish translation.

The forum and website are being moved to a unified platform together with BAW EDU.